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前  言 

进入大数据时代，人们对数据的管理和应用越来越广泛，应用开

发者则更加努力提升用户体验。 

数据可视化可以将一大堆密密麻麻的数字转成图表形式，更直观

地向用户展示数据之间的联系和变化情况，减少用户的阅读和思考时

间，帮助更好地做出决策。  

数据可视化工具是实现上述功能的利器，可用来创建对话框或其

它界面，以一种适合于变量或对象数据类型的方式来显示变量或对象。

例如，HTML 可视化工具解释 HTML 字符串，并按照该字符串出现

在浏览器窗口中时的样子显示结果；位图可视化工具解释位图结构并

显示该位图结构表示的图形。 

上期专辑我们介绍了 Arbor.js、CartoDB、Chroma.js、Circos、D3.js、 

Cola.js等 6种工具，本期专辑我们将继续介绍十个新工具。 
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（续上期） 

七、 Cubism.js  

类型: 库 

技术: JavaScript 

开源协议: MIT 

1. Cubism.js 简介 

Cubism.js 是上期专辑中的 D3 可视化库的一个插件，用于实现时序图。使用 Cubism 可

以构建更好的实时仪表板，效果如下图所示。 

 

 2. 特点优势  

可测量化 

Cubism 抓取时间序列数据时，在初次抓取并显示数据之后，仅筛选并获取

最新增加的数据，这样就有效降低了服务器的负载。Cubism 在展示数据的时候

依然采取类似的增量方法，应用 Canvas 把图表向左移一个像素。这样的抓取与

展示方法有效的降低了服务器的负载，使 Cubism 可以轻易在每 10 秒更新上百

条数据。虽然 Cubism 抓取数据的时候并不是完全同步的，但是展示的过程是同

步的，因此图表的更新也是同步了，这进一步提高了数据的可读性。 

高效化 

Cubism 提供一种更感官化的计量方式：几倍于传统图表的时间刻度使快速

比较成为可能。Cubism 的水平图表比标准图表更好的利用了垂直空间，使用户

可以在一瞥之下观看到更多的信息，并增加了发现信息的可能性。 

举例说，如果将一个 120 像素高的图表压缩为 30 像素，那么就损失掉了 75%

的分辨率，由此将增加观测到细微变化的难度。但是这种分辨率损失的问题被

Cubism 很好的解决了，Cubism 在展示数据时，较大的值会在图表中用深色标出，

而负值则会在图表顶部倒置。使用多种颜色表达数值的方法降低了对垂直空间的
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依赖。 

这种水平图表通过展示的位置（正置/倒置）与颜色（浅色/深色等）不同，

加强了用户的感官体验。 

灵活化 

Cubism的数据来源很灵活，这个插件现在已经内置到了Graphit和Cube中，

但是数据源并不仅限于此，它目前已经可以拓展应用多个数据源中。客户端

metric arithmetic 实现了 Cubism 的多数据源操作，从而进一步提高了产品的灵活

度。Cubism 的模数化部件同样提供了多种自定义功能。 

3. 资源链接 

主页：http://square.github.com/cubism/ 

源码地址：https://github.com/square/cubism 

数据资源：http://square.github.com/cube/ 

 

八、 ColorBrewer 

类型: Web 应用&库 

技术: JavaScript,Flash 

开源协议: Apache 

1. ColorBrewer 简介 

ColorBrewer 是专门为帮助用户选择地图和其他图片图表等配色方案而设计

的轻量级在线工具，本工具操作简单，即使没有编程基础也可以轻松使用。 

 

2. 使用入门  

http://square.github.com/cubism/
https://github.com/square/cubism
http://square.github.com/cube/
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ColorBrewer 的使用十分简单，只要在网站上依次点击完成出现的“step1”，

“step2”等对话框，就会出展示出与你的数据相匹配的配色方案。 

当对话框出现的时候，不要忘记点击“step3”中的 mini legends，他们会加

载不同的配色方案。 

3. 资源链接 

主页：http://colorbrewer2.org/ 

 

九、 Cytoscape 

类型: 库 

技术: Java 

开源协议: GPL 

1. Cytoscape 简介 

Cytoscape 是一款图形化显示网络并进行分析和编辑的软件，它支持多种网

络描述格式，也可以用以 Tab 制表符分隔的文本文档或 Microsoft Excel 文件作为

输入，或者利用软件本身的编辑器模块直接构建网络。它是一个复杂网络的可视

化工具。适用于各种问题领域，包括生物信息学，社会网络分析，语义网络 

Cytoscape 还能够为网络添加丰富的注释信息，并且可以利用自身以及第三

方开发的大量功能插件，针对网络问题进行深入分析。 

2. Cytoscape 入门 

此处以 Cytoscape 在生物学上的应用为例简单介绍其基本操作。 

1） 准备工作 

Cytoscape 可以本地安装使用，也可以在线使用。启动 Cytoscape 后，需要下

载两个样例文件。以 sif 为后缀名的是蛋白相互作用网络信息，里面的蛋白以数

字形式区别，以 na 为后缀名的是各数字 id 的注释，两者的文件名必须相同才能

关联起来。 

sif 文件的打开\导入有两种方式：File → Import → Network(Multiple File 

Types)或者直接 Ctrol+L，na 文件是 File → Import → Node Attributes。Network

导入之后有多种显示风格，2.8 版默认风格下，圆圈是各蛋白，称为节点（node），

其间各线为 edge，代表相互 作用。点中圆圈就选中了一个节点，想要多选，可

以采用同时按 Shift 的方法，也可以先在 Select → Mouse Drag Selects 设置好选

http://www.plob.org/tag/cytoscape
http://www.plob.org/tag/cytoscape
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node 还是选 edge，然后鼠标拖放，可以多选。 

此外还可以有目的地选择。比如可以 Select → Nodes → By Name，然后输

入蛋白 id，即可选中此节点，此操作的快捷键是 Ctrl+F。 

如果已经选中了节点，还可以 Select → Nodes → First neighbors of selected 

nodes，可将所选蛋白的直接相互作用蛋白选中，再选 File → New → Network 

→ From selected nodes, all edges，即将相互作用网络的一个子网络剥离出来。 

Layout 菜单的功能比较多，是关于相互作用网络图的组织原则的。相互作用

网络图下是查看节点或连线所代表的信息的地方，称为 data panel。按 Attributes

按钮会弹出一个小窗口，可选择需要列出的栏目的名字，比如 id，或者对应的基

因名，当然这个基因名信息是从 na 文件里导入的。 

左边的窗口是有多个 tab 的控制面板。Network 那个 tab 里可以在导入的 sif

里切换。VizMapper tab 里可以定制显示样式，比如圆圈变成方形，或者变大一

些，或者换个底色，连线换个粗细和颜色等等。如果找不到的话，Cytoscape 的

菜单栏下还有几个快捷按钮，其中有一个可以打开 VizMapper。各种样式设置好

之后一定要点 Apply，还可以新建或者另存，便于把所有的网络个性化。 

Cytoscape 还支持从网上直接导入相互作用网络，也是在 File → Import → 

Network (Multiple File Types)一步，选择 remote，然后输入 url，可兼容 SBML 格

式。 

2） 筛选和编辑 

首先，用拖放选一些节点和连线（还是海选），然后 Select → Use Filters，

控制面板里即出现 Filters tab，在此 tab 中点 Options，在弹出的下拉菜单中选

Create new filter。 

之后开始定义筛选条件，比如连线的类型：在 Filter Definition 里选

edge.interaction，然后点 Add。此时指定了筛选依据，而具体条件还没指明。在

Advanced 里，输入 non_core 或者 core 之类的连线类型，当然 Y2H 的也行。最

后一定要按一下 tab 左下角的 Apply。 

此时选中了相互作用类型为 non_core 的节点和连线。之后可以进行多种操

作。比如 Edit → Delete Selected Nodes/Edges，这样这些 non_core 的东西就统统

删除了，剩下筛选出来的的蛋白及其相互作用数据信息。 

可是还有一些和其他蛋白没有相互作用的蛋白，把它们找出来、删除。很简

单，如法炮制，仅仅把相互作用筛选条件换成“*”就行，选好后再利用 New → 

Network → From selected nodes, selected edges，调整一下 layout：Layout → 

spring-embedded layout，这张图里只有有相互作用的蛋白。不过其实任务还剩个

尾巴，有些蛋白可与自身相互作用，这部分蛋白还在这张图里。 

导入的文件也并不总是完美的，有时需要添加和删除某些节点和连线，此时

http://www.plob.org/tag/cytoscape
http://www.plob.org/tag/cytoscape
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需要用到控制面板里的 Editor tab。添加节点的话就在标有“Add a Node”的节点

上点左键，然后把节点拖到右边的相互作用网络图里，在数据面板的 Node 

Attribute Browser 里可以看到新添的节点 id 为 node0。在此窗口里点相应栏目，

即可修改其属性，比如基因名之类的。 

添加连线的话，在 Editor tab 里点“Directed Edge”，如法炮制，拖到右边图

里某个节点上，确定相互作用的一方，然后把另一端拖到某个节点之上。连线属

性在数据面板的 Edge Attribute Browser 里查看和修改。 

删除：选中要删的内容，然后 Edit → Delete Selected Nodes/Edges，此操作

的快捷键是 Del。 

3） 获取外部数据 

获取外部数据部分包括： 

a. 从外部服务（比如 SGD 和 BIND）下载 Cytocape 格式的数据。 

b. 用 cPath插件获取外部数据，其中 cPath从2.4版以后已经整合到Cytoscape

核心包里了。 

SGD 是酵母的库，Saccharomyces Genome Database，提供 physical 和

genetic 相互作用的信息，提供 sif 格式的下载，地址：http://db.yeastgenome.org/ 

cgi-bin/batchDownload。下载页面的说明很简单，总之是指定想下的东西再重定

向到另外一个页面，然后“另存为”操作就行了。 

BIND（Biomolecular Interaction Network Database）主要提供蛋白相互作用信

息，现在整合到BOND 库里了。下载地址 http://bond.unleashedinformatics.com/，

免费，需注册。登录后进入首页，搜索目标分子，搜到的相关信息分为五类：

summary、sequences、interactions、complexes 和 pathways。打开 interactions，在

结果栏的右上角有导出功能，选择导出成“sif”格式即可。 

另外还有 Pathway Commons 库，地址 http://www.pathwaycommons.org/。目

前已经整合的库包括：BioGRID、Cancer Cell Map、HPRD、HumanCyc、IMID、

IntAct、MINT、NCI / Nature Pathway Interaction Database，具体的说明见 Pathguide。

Pathguide 也是个有价值的网站，是个介绍全部 325 个途径和相互作用相关的数

据库的概况的数据库，相当于目录或者提要。从这里你可以找到蛋白-蛋白相互

作用、代谢途径、信号传导途径、表达途径、转录因子/基因调控网络、蛋白-复

合物相互作用、 genetic 相互作用网络、protein sequence focused 等等类型的数据

库，查看其概况，然后决定去哪个库搜索信息。 

最后是用 cPath 插件从 CPpath 数据库直接获取数据，后者从 2008 开始就不

更新了，而且建议用户使用 Pathway commons。 

下载多个源的相互作用网络文件后，可以融合成一张图，需要用到 Graph 

Merge 插件。这个插件也整合进核心包了，在 Plugins 下的 Advanced Network 

http://www.plob.org/tag/cytoscape
http://www.plob.org/tag/cytoscape
http://bond.unleashedinformatics.com/
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Merge。 

4） 表达分析 

首先，下载三个文件：galFiltered.sif、galExpData.pvals 和 galExpData.mrna。

接下来通过操作下载的示例文件来学习： 

○1 导入 galFiltered.sif，弹出数据面板和结果面板，最大化画布，用 spring-

embedded 风格显示。 

○2  文本编辑器打开 mrna 文件，可以看到第一行是数据标签。对应于相互

作用网络图，第一栏为节点名称，必须和 sif 文件里的节点名一模一样哟；第二

栏是基因 座名，Cytoscape 里目前不显示；后面各栏是表达信息。各栏之间用

whitespace 隔开。 

○3 导入表达信息：Import → Attribute/Expression Matrix...，快捷键 Ctrl+E。

导入后，Node Attribute Browser 里就能看到这个节点的表达量了。 

基础工作就此结束，下面是进阶教程。 

○4 首先可以根据表达量高低给节点上不同的颜色。在 VizMapper 里先新建

个显示风格，然后双击 Node color，选择按照某类表达量分类，选 continuous 

mapping，然后点开下面那张颜色图设置阈值和颜色。别忘了按 Apply。 

下面是一些背景知识。Gal1、Gal4 和 Gal80 都是酵母转录因子，在相互作用 

网络里分别对应 YBR020W、YPL248C 和 YML051W。相互作用有两种类型：

protein-protein (pp)和 protein-DNA (pd)。表达量信息分别是 Gal1、Gal4 和 Gal80

的表达异常情况下的值。可以看到这三个转录因子表达异常影响到的基因。 

○5 首先要把 pp 相互作用除去。用 filter 和 Delete Selected Nodes and Edges。

然后用 yFiles Organic layout 查看剩下的连线。 

○6 查看剩下的强烈诱导或抑制的节点，选择它们，选择其直接相邻节点，

复制到新的相互作用图里便于查看。然后可以好好看看转录因子对不同蛋白的表

达量的作用了。 

以上就是以生物学应用为例的简单入门介绍，更多详细内容及进阶操作可参

见： 

http://opentutorials.cgl.ucsf.edu/index.php/Portal:Cytoscape3 

3. 资源链接 

主页：http://www.cytoscape.org/ 

http://www.plob.org/tag/cytoscape
http://opentutorials.cgl.ucsf.edu/index.php/Portal:Cytoscape3
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源码地址：https://github.com/cytoscape 

教程：http://opentutorials.cgl.ucsf.edu/index.php/Portal:Cytoscape3 

案例：http://www.cytoscape.org/screenshots.html 

 

十、 Dance.js 

技术: JavaScript 

类型: 库 

开源协议: MI 

1. Dance.js 简介 

Dance.js 是一个简单的数据驱动的可视化框架。它基本上与 Backbone.js 的

功能类似，但富含一些流行的 D3.js 可视化框架思想。下图展示了利用 Dance.js

工具制作的可视化人口分布图。 

 

2. 基本原理 

Dance.js 是一个以数据为驱动的可视化工具，其生成的图片是由数据以及处

理的可视化方法（比如滤镜及所选择的变量等）决定的。当用户改变数据或者可

视化变量中的任何一个的时候，生成的图片都会根据变化做出相应的适应。 

Dance.js 应用了一些基本的原理，诸如 Data Joins（一个由 D3.js 引入的功

能），计量功能，以及动画制作功能。在官方网站的教程中，他们利用了一个最

简单的可视化框架 Dance.js 以及 Data.js 一起来展示与获取本地数据。 

3. 资源链接 

源码地址：https://github.com/michael/dance 

http://www.cytoscape.org/screenshots.html
https://github.com/michael/dance
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教程：http://quasipartikel.at/2012/04/25/dancing-with-data/ 

十一、 Data.js 

技术: JavaScript 

类型: 库 

开源协议:MIT 

1. Data.js 简介 

Data.js 是一个数据表示框架，为领域数据提供统一的接口。它是一个跨浏览

器的 JS 数据库，他通过协调互联网协议与浏览器特性来支持以数据为中心的网

络应用。Data.js 的设计理念是小巧，迅捷，提供一个平台，使网络应用可以更好

的为数据做支持。 

 

2. 功能介绍 

Data.js 是一个跨浏览器的 JS 数据库，他通过协调互联网协议与浏览器特性

来支持以数据为中心的网络应用。Data.js 的设计理念是小巧，迅捷，提供一个平

台，使网络应用可以更好的为数据做支持。 

目前这个库提供的功能包括：与 OData 服务交互，协调浏览器储存机制的功

能如 IndexedDB，以及提供一个可以通过合并远程服务与本地存储功能来实现高

效获取数据列表的易用的 API。 

OData 的服务支持包括接受数据，提交变量以及激活服务操作。必要的话，

其 API 可以感知到元数据，并且多线程操作以最小化回路操作。关于 OData 的

教程资源可以在 http://www.odata.org/developers 找到。 

http://quasipartikel.at/2012/04/25/dancing-with-data/
http://www.odata.org/developers
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3. 资源链接 

主页：http://substance.io/michael/data-js 

源码地址：https://github.com/michael/data 

文档：http://code.substance.io/docs/substance-manual/ 

 

十二、 DataWrangler 

类型: Web 应用 

技术: HTML 

开源协议: Free to use 

运行环境：任何网络浏览器 

1. DataWrangler 简介 

DataWrangler 是基于网络的服务，它是由斯坦福大学可视化组设计来进行清

洗和重排数据的，因此，它的格式也适用于电子表格等应用程序。 

 

2. DataWrangler 入门 

在进行数据分析和可视化之前，经常需要先“清洗”数据。这是因为可能有

些词条列表里是“New York City”，而其他人写成“New York, NY”。然而，用户

在看到某些模式前得将各种各样的输入词汇标准化。又或者，出现一些数值输入

错误，比如错别字。 

在操作时，点击一行或一列，DataWrangler 会有修改的建议。例如，用户点

击了一行空行，一些建议就出弹出来，像“删除行”或“删除空行”等。 

同时，DataWrangler 有一个历史记录，允许用户很容易地实现撤消功能。 

DataWrangler 的文本编辑非常简单。例如，当选择大标题为“Reported crime 

in Alabama”的样本数据的某行的“Alabama”，然后选择另一组数据的“Alaska”，

它会建议提取每州的名字。把鼠标停留在建议上，就可以看到用红色突出显示的

http://substance.io/michael/data-js
https://github.com/michael/data
http://code.substance.io/docs/substance-manual/
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行。 

DataWrangler 是基于网络的服务，非常方便使用。但不要忘记，代价是必须

把数据上传到外部网站。也就是说，对于敏感的内部数据，DataWrangler 就不是

合适的选择了。不过，未来会有独立的桌面版本。另一个必须考虑的事情是，

DataWrangler 是用现行的 alpha 码编写的，它的创建者说它（alpha 码）还在改进

中。 

3. 资源链接 

主页: http://vis.stanford.edu/wrangler/ 

论文: http://vis.stanford.edu/papers/wrangler 

 

十三、 Envision.js 

类型: 库 

技术: JavaScript 

开源协议: MIT 

1. Envision.js 简介 

Envision.js 是一个 JavaScript 库，通过使用它可以简化可交互式 HTML5 数

据可视化的创建过程。它自带 2 种图表类型：TimeSeries 和 Finance，但是用户

可以通过它提供的 API 来构建自定义图表，从而实现更多的功能。这个库是基

于 Flotr2 和 HTML5 Canvas 构建的。 

 

Envision.js 使用的是 FlashCanvas 技术，可以支持大部分流行的 PC 端浏览

器，包括 IE6-8，以及一些内核是 WebKit 的移动端浏览器。 

2. 功能举例 

http://vis.stanford.edu/wrangler/
http://vis.stanford.edu/papers/wrangler
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实时数据动态表 

在时序表模板中输入实时数据，可以实现实时数据动态表的功能，当新数据

随着时间不断增加的时候，图表也会随之变化从而展现出新的数据。 

时序表 

使用 Envision.js 的时序表模版可以制作 HTML5 的时序表，该模板提供了内

置的常用可视化关联方法，操作相对简单。 

金融图表 

在金融模版内导入全域命名空间数据即可得到 HTML5 金融表格。其中坐标

轴标签等可以自定义。 

除了上述利用模版制作的表格之外，用户还可以通过自定义 API 等方法来

实现自定义作图。 

3. 资源链接 

主页: http://www.humblesoftware.com/envision 

源码地址: https://github.com/HumbleSoftware/envisionjs 

 

十四、 Flare 

类型: 库 

技术: Flash 

开源协议: BSD 

1. Flare 简介 

Tokyo Cabinet (TC) 是日本第一大 SNS 网站 mixi 开发的，而 Flare 是日本第

二大 SNS 网站 green.jp 开发的。Flare 简单的说就是给 TC 添加了 scale 功能。自

己另外给 TC 写了网络服务器，Flare 的主要特点就是支持 scale 能力，他在网络

服务端之前添加了一个 node server，来管理后端的多个服务器节点，因此可以动

态添加数据库服务节点，删除服务器节点，也支持 failover。如果你的使用场景

必须要让 TC 可以 scale，那么可以考虑 flare。 

http://www.humblesoftware.com/envision
https://github.com/HumbleSoftware/envisionjs
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Flare 的缺点是它只支持 memcached 协议，因此当用户使用 flare 的时候，就

不能使用 TC 的 table 数据结构了，只能使用 TC 的 key-value 数据结构存储。 

2. 资源链接 

主页：http://flare.prefuse.org/ 

源码地址：https://github.com/prefuse/Flare 

 

十五、 GeoCommons 

类型: Web Application & API 

技术: JavaScript, Ruby 

开源协议: Various 

1. GeoCommons 简介 

GeoIQ 是一个为技术人员及非技术人员提供地学数据管理，可视化以及分析

平台。基于这个平台，用户即使没有接受过大量的培训，也可以快速直观的做出

较为正确的决定。 

GeoCommons 是基于 GeoIQ 的一个社区，目前有超过 25000 活跃用户，这

些用户每天发布并共享数以万计全球范围的地图地理数据。在 GeoCommons 社

区上，任何用户都可以贡献共享数据，也可以轻松的创作地图以及与他人合作。 

http://flare.prefuse.org/
https://github.com/prefuse/Flare
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2. GeoCommons 入门：在 5 分钟做出自己的地图  

利用 GeoCommons 制作地图十分方便。用户可以上传自己的原始数据，也

可以从网站共享的数以万计的数据中选择内容。自己上传的数据可以是电子表格

格式，也可以是 KML 格式。如果上传的数据中不含有经纬度等信息，可以将数

据与网站上现存的文件相匹配，或者自行使用 Geocoder 编码器加入经纬度信息。

用户也可以通过网页地址链接来加载地理数据。 

当数据完成上传后，只要点击主页或数据站中的“Make a Map”按钮就可以

用这些数据制作地图了。如果你已经有了一张地图，那么可以点击“Add to Map”

按钮来添加数据。你可以自定义样式颜色等内容。GeoCommons 提供一个便捷的

制作途径，被称为“Happy Path”，根据提示也可以很便捷的完成地图的制作以及

自定义。 

完成制作后可以保存并在社区中共享你做出的地图。 

3. 资源链接 

主页：http://geocommons.com/ 

API 文档：http://geocommons.com/api/ 

GitHub 用户：http://github.com/geocommons/ 

 

十六、 Gephi 

类型: Desktop Application 

技术: Windows, Linux, MacOS X, Java 

开源协议: CDDL, GPL 3 

http://geocommons.com/
http://geocommons.com/api/
http://github.com/geocommons/
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1. Gephi 简介 

Gephi 是一款开源免费跨平台基于 JVM 的复杂网络分析软件, 其主要用于

各种网络和复杂系统，动态和分层图的交互可视化与探测开源工具。可用作：探

索性数据分析，链接分析，社交网络分析，生物网络分析等。Gephi 是一款信息

数据可视化利器。 

 

2. 使用举例：利用 python、Gephi 绘制人人的社交网络图 

这里以使用 Gephi 绘制人人网社交网络图为例，简单介绍 Gephi 的应用及使

用方法。 

1）登陆自己的人人网 

进入到网页 http://friend.renren.com/myfriendlistx.do#item_0 右键查看源代

码，将下图中自己好友列表的一行复制出来，保存为 myFriends.dat。 

 

2） 运行下列的源代码： 

[python] view plaincopy 

import urllib,urllib2,cookielib   

http://blog.csdn.net/zdw12242/article/details/8687644
http://blog.csdn.net/zdw12242/article/details/8687644
http://blog.csdn.net/zdw12242/article/details/8687644
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import re   

   

def MyFriends(filename):   

    patt2='"id":(\d+),"vip":[\s\S]+?"name":"([\s\S]+?)",\   

"head":"([\s\S]+?)","groups":\["([\s\S]+?)"\]'  #id,name,head,groups   

    patt='"id":(\d+),'   

    f=open(filename,'r')   

    for eachLine in f:   

        friendList=re.findall(patt,eachLine)   

    return friendList   

   

def Login(t,JSESSIONID):   

    cookie={'t':t,'JSESSIONID':JSESSIONID}   

    cookies=''.join(x+'='+cookie[x]+';' for x in cookie)   

    return cookies   

   

def ShareFriends(cookies,friendID):   

    opener=urllib2.build_opener(urllib2.HTTPCookieProcessor(\   

        cookielib.CookieJar()))   

    urllib2.install_opener(opener)   

    req = urllib2.Request('http://friend.renren.com/shareFriends?\   

t=0.8142646627966315&p={"init":true,"uid":true,"uhead":true,\   

"uname":true,"group":true,"net":true,\   

"param":{"guest":'+friendID+'}}')   

    req.add_header('Cookie', cookies)   

    content = urllib2.urlopen(req).read()   

    patt='"id":(\d+),"netName":"'   

    friends=re.findall(patt,content)   

    return friends   

   

def AllFriendsLinkCSV(cookies,friendList,filename):   

    f=open(filename,'w')   

    f.write('Source,Target\n')   

    for friendID in friendList:   

        f.write('xxxx,'+friendID+'\n')  # replace XXXX with your ID   
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    for friendID in friendList:   

        friends=ShareFriends(cookies,friendID)   

        for ID in friends:   

            f.write(friendID+','+ID+'\n')   

    f.close()   

       

def main():   

    friendList=MyFriends('myFriends.data2')   

    t,JSESSIONID='xxxxx','xxxxx'   

    cookies=Login(t,JSESSIONID)   

    AllFriendsLinkCSV(cookies,friendList,'FriendsLink.csv')   

       

if __name__=='__main__':   

    main()   

函数 MyFriends 用于获取自己的好友列表，ShareFriends 用于获取和某个

好友的共同好友，AllFriendsLinkCSV 按照 Gephi 的指定格式将好友关系保存为

csv 文件。main 函数中的 t,JSESSIONID 通过如下方式获取后，取代上面代码中

的 xxxxx：在人人页面中右键，审查元素，资源选项下的红色覆盖部分： 

 

3） 替换 t 和 JSESSIONID 值后运行上述代码，得到 FriendsLink.csv。在 Gephi

中导入 csv 文件，回到概览就可以看见网络图，经过一系列处理后就可以得到自

己的如本节开始处的社交图了。 

3. 资源链接 

主页：http://gephi.org/ 

文档：http://wiki.gephi.org/index.php/Main_Page/ 

 

 

http://gephi.org/
http://wiki.gephi.org/index.php/Main_Page/
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